I just grabbed the lastest Ruby code from cvs and compiled it on FreeBSD 
4.2.  When attempting to require 'pstore' I get the following error:

/usr/local/lib/ruby/1.7/pstore.rb:16:in `require': No such file to load 
-- digest/md5 (LoadError)
         from /usr/local/lib/ruby/1.7/pstore.rb:16

Any idea what I need to do to work around this error?  Any help is 
greatly appreciated.  Works great with Ruby 1.6.5.

Thanks, Michael