The entire 1.8.x series should be backward compatible to 1.8.6 NOT 
forward compatible to 1.9.x.
-- 
Posted via http://www.ruby-forum.com/.