On Thu, Feb 12, 2009 at 11:07 AM, Gregory Brown
<gregory.t.brown / gmail.com> wrote:
> We're not in disagreement here.  It's just been my experience that I
> can write code on 1.8.6 without thinking about backwards
> compatibility with earlier versions, for the most part.  We all know
> that things have changed, but not in so radical a fashion.
>
> What I was supporting was a stable 'flavor' of Ruby 1.8, in the form
> of a EY supported 1.8.6.
>
> And I agree completely that this solves the issue without forcing
> people in one direction or the other.  If ruby-core wishes to support
> 1.8.7 and beyond, those who like the idea will not be left
> disappointed.

But that still leaves a communication gap between two groups of
implementers -- Engine Yard and "Ruby-Core" -- and the Linux distros
that are probably only going to package *one* Ruby and are expecting
*their* user base to have working Ruby and Rails and gems! Right now,
I'm running openSUSE 11.1, which ships 1.8.7. IIRC RHEL 5 / CentOS 5
are still shipping 1.8.5, and I have no idea what's in the two most
recent versions of Ubuntu, or what's going to be in Debian Lenny when
it releases in  the near future. In short, the distro Ruby herds need
to be in the loop, or the Ruby community will have a bunch of
implementations to choose from.
>
> -greg
>
> --
> Technical Blaag at: http://blog.majesticseacreature.com
>  Non-tech stuff at: http://metametta.blogspot.com
> "Ruby Best Practices"  Book now in O'Reilly Roughcuts:
> http://rubybestpractices.com
>
>



-- 
M. Edward (Ed) Borasky

I've never met a happy clam. In fact, most of them were pretty steamed.