2009/2/12 Phlip <phlip2005 / gmail.com>:

>> Important is backwards compatibility and Ruby 1.8.7
>> is backwards compatible. Nobody so far has shown
>> where 1.8.7 is not backwards compatible.
>
> require 'rubynode'

From http://rubynode.rubyforge.org/:
  "RubyNode is a library that allows read only access to Ruby's
  internal NODE structure."

It's cool that such libraries exist, but AFAIK MRI's
internal AST is  not part of its public API, much
less part of Ruby 1.8, the language.

Stefan