Hi Craig,

  In mail "Re: installing mod_ruby --> seg fault in ruby-rdtool"
    Craig Burgess <craig / CheetahUSA.net> wrote:

> Here are the results:

Thanks. All results seems good.


> then I tried the same test and
> 
> ======================
> felix# racc rd/rdblockparser.ry
> /usr/local/lib/ruby/site_ruby/1.6/racc/output.rb:239: [BUG] Segmentation
> fault
> ruby 1.6.6 (2001-12-26) [alpha-freebsd4]
> Abort (core dumped)

............. I cannot understand what is happen!!  :-(

OK, We should choose simplest way. I cannot resolve your SEGV
problem, but I realize you need not to use racc because racc
generate same output on all platform. Here's my rdtool package:

  http://i.loveruby.net/archive/rdtool/rdtool-0.6.10-all-1.tar.gz

This package includes pre-compiled racc output already.
This package also includes all things you need to use rdtool,
so you do not need to install any other packages. Installation is:

  $ tar zxf rdtool-0.6.10-all-1.tar.gz
  $ cd rdtool-0.6.10-all-1/
  $ ruby setup.rb config
  $ ruby setup.rb setup
  $ su
  # ruby setup.rb install

This package may coflict with FreeBSD ports, so you may want to
instal them in to your favarite directry. If you want so, replace
"setup.rb config" line with this command:

  $ ruby setup.rb config --prefix=~/lib/ruby

And add it to the ruby's load path:

  $ export RUBYLIB=~/lib/ruby

(I'm using bash in example.)


If you cannot get success with this package, you should recompile
ruby by yourself, using your compiler. Passing CFLAGS="-O0" (-O + zero)
to configure, is better.


> (BTW - thank you for the link to "blade"! I can view messages/navigate
> with netscape 4.7/FreeBSD but see "empty" messages in both Netscape 6.2
> and MS Outlook in Win2K... Odd?) 

Did you turn on/off JavaScript?
If JavaScript failes, page output is stopped.

-- Minero Aoki