You might also try these Windows-ized versions of system and `

  http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/10006

> -----Original Message-----
> From: tgphelps / iglou.com [mailto:tgphelps / iglou.com]
> Sent: Monday, January 28, 2002 1:55 PM
> To: ruby-talk / ruby-lang.org
> Subject: Re: howto copy files from NT box to NT servers
> 
> 
> "copy" is a builtin command of the CMD shell. You probably 
> have to run a 
> command similar to:
> cmd /c copy ...
> 
> 
> 
> -----Original Message-----
> From: Dinakar Desai <Desai.Dinakar / mayo.edu>
> To: ruby-talk / ruby-lang.org (ruby-talk ML)
> Date: Tue, 29 Jan 2002 04:48:20 +0900
> Subject: howto copy files from NT box to NT servers
> 
> > Hello all:
> > 
> > I have NT box and five NT servers on LAN. I would like to copy few
> > files from
> > NT box to NT servers quite often. I tried following code 
> but something
> > is
> > wrong and does not work.
> > 
> > #!/usr/bin/env ruby
> > 
> > 
> > print "copying files from c drive to citrix server";
> > 
> > `copy c:/pb/workstationCTS/build/pdef_*.pbd
> > //lpsctx07/workstationCTS\$/protdef/release_1.0.2/`;
> > 
> > I also tried with system command and it does not work. I get the
> > following
> > error
> > 
> > <error>
> > copy: not found
> > //lpsctx07/workstationCTS$/protdef/release_1.0.2/: not found
> > </error>
> > 
> > Can someone suggest some workable solution.  If I try the 
> same command
> > at
> > command prompt, it works.
> > 
> > any help is appreciated.
> > 
> > Thank you.
> > 
> > dinakar
> > 
> > 
> > 
> > 
>