Hi --

On Sun, 1 Feb 2009, Suraj Kurapati wrote:

> James Gray wrote:
>> Gregory Brown wrote:
>>> Matz wrote:
>>>> We still don't have consensus on the name.  eigenclass?
>>>> In that case, should we rename singleton_method to eigenmethod?
>>>
>>> I wonder if this controversy has died down.   There are people with
>>> their favorites, sure, but does anyone really oppose singleton_class?
>>
>> I'm for singleton_class.  It's what the official documentation has
>> used for a long time now.  It's also not like it will be the only
>> overloaded term in computing.
>
> I filed a request for Object#singleton_class in the Ruby Issue Tracking
> System:
>
>  http://redmine.ruby-lang.org/issues/show/1082

Good ol' RCR 231, or whatever it was :-)


David

-- 
David A. Black / Ruby Power and Light, LLC
Ruby/Rails consulting & training: http://www.rubypal.com
Coming in 2009: The Well-Grounded Rubyist (http://manning.com/black2)

http://www.wishsight.com => Independent, social wishlist management!