James Gray wrote:
> Gregory Brown wrote:
>> Matz wrote:
>>> We still don't have consensus on the name.  eigenclass?
>>> In that case, should we rename singleton_method to eigenmethod?
>>
>> I wonder if this controversy has died down.   There are people with
>> their favorites, sure, but does anyone really oppose singleton_class?
> 
> I'm for singleton_class.  It's what the official documentation has
> used for a long time now.  It's also not like it will be the only
> overloaded term in computing.

I filed a request for Object#singleton_class in the Ruby Issue Tracking 
System:

  http://redmine.ruby-lang.org/issues/show/1082

Thanks for your consideration.
-- 
Posted via http://www.ruby-forum.com/.