With this file:

C:\dev\thesis_p2pwebcode\src>cat example.rb
require 'optparse'

   OptionParser.new do |opts|

    opts.on('-p', '--do_multiples_with_variant=NAME', 'multiples variant
ex: ') do |name|
    end
   end.parse!


I get the following output:
Usage: example [options]
    -p=NAME                          multiples variant ex:
        --do_multiples_with_variant


however it doesn't actually accept -p=NAME
it accepts -pNAME

Anybody know if this is expected?
Thanks!
-=r
-- 
Posted via http://www.ruby-forum.com/.