On Fri, Jan 30, 2009 at 4:28 PM, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
> Hi,
>
> In message "Re: Object#singleton_class in Ruby 1.9?"
>    on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" <dblack / rubypal.com> writes:
>
> |> Was Object#singleton_class (or #eigen_class or #meta_class) planned for
> |> Ruby 1.9 or 2.0?
> |
> |Not that I remember hearing about. I'd certainly like to see it.
>
> We still don't have consensus on the name.  eigenclass?
> In that case, should we rename singleton_method to eigenmethod?
>
>                                                        matz.

Actually I am totally against it, in core that is. It would be nice to
have a standard library extension for this, e.g. meta-ruby.
I was really impressed about by David's keynote at Rubyconf. Just
thought to share this thoughts in case I am not a minority.
Cheers
Robert
>



-- 
It is change, continuing change, inevitable change, that is the
dominant factor in society today. No sensible decision can be made any
longer without taking into account not only the world as it is, but
the world as it will be ... ~ Isaac Asimov