On Fri, Jan 30, 2009 at 3:28 PM, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
> Hi,
>
> In message "Re: Object#singleton_class in Ruby 1.9?"
>    on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" <dblack / rubypal.com> writes:
>
> |> Was Object#singleton_class (or #eigen_class or #meta_class) planned for
> |> Ruby 1.9 or 2.0?
> |
> |Not that I remember hearing about. I'd certainly like to see it.
>
> We still don't have consensus on the name.  eigenclass?
> In that case, should we rename singleton_method to eigenmethod?
>
>                                                        matz.

Personally, I prefer singleton_class. But I would rather it had an
official name than my preference held anything up.

I suspect there is a strong consensus that it should be named,
whatever the name. I doubt we'll ever get consensus on ~what~ that
name should be. :)

Regards,
Sean