On Fri, Jan 30, 2009 at 5:46 PM, Gary Wright <gwtmp01 / mac.com> wrote:
>
> On Jan 30, 2009, at 10:53 AM, James Gray wrote:
>>
>> I'm for singleton_class.  It's what the official documentation has used
>> for a long time now.  It's also not like it will be the only overloaded term
>> in computing.
>
>
> eigenton_class?  :-)
>
> eigen_class or singleton_class doesn't really matter to
> me at this point but I do feel strongly that the object
> returned by:
>
>        (class <<obj; self; end)
>
> should be available via a simple method call rather
> than only via that expression.

I completely agree with this point of view. I don't mind which name
gets chosen, but please, choose one :-).

Jesus.