Thomas Sawyer wrote:
> Yukihiro Matsumoto wrote:
>> We still don't have consensus on the name.  eigenclass?
>> In that case, should we rename singleton_method to eigenmethod?
> 
> Since you make mention of "eigenclass", that would seem to be your bent. 
> And I say, go for it! "eigenmethod"? Fantastic! Do it, do it, do it!

In that case, could we make the names more readable by adding an 
underscore after "eigen"?  I find it more difficult to parse the names 
otherwise.

Object#eigen_class
Object#eigen_methods
Object#define_eigen_method

> Not to mention, no more Singleton vs. singleton controversy.

This is indeed a good benefit.

Thanks for your consideration.
-- 
Posted via http://www.ruby-forum.com/.