Yukihiro Matsumoto wrote:
> Hi,
> 
> In message "Re: Object#singleton_class in Ruby 1.9?"
>     on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" 
> <dblack / rubypal.com> writes:
> 
> |> Was Object#singleton_class (or #eigen_class or #meta_class) planned for
> |> Ruby 1.9 or 2.0?
> |
> |Not that I remember hearing about. I'd certainly like to see it.
> 
> We still don't have consensus on the name.  eigenclass?

Sorry, I only mentioned the other names because they were all proposed 
when we first discussed this (back in 2006, I think).  Ruby was the 
first language where I learned the concept of "singleton class" (not the 
design pattern) so I think it makes sense to keep that name.

> In that case, should we rename singleton_method to eigenmethod?

Is this not a larger (disruptive) change than simply adding a new 
Object#singleton_class method?

Thanks for your consideration.
-- 
Posted via http://www.ruby-forum.com/.