On Jan 30, 2009, at 9:47 AM, Gregory Brown wrote:

> On Fri, Jan 30, 2009 at 10:28 AM, Yukihiro Matsumoto <matz / ruby-lang.org 
> > wrote:
>> Hi,
>>
>> In message "Re: Object#singleton_class in Ruby 1.9?"
>>   on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" <dblack / rubypal.com 
>> > writes:
>>
>> |> Was Object#singleton_class (or #eigen_class or #meta_class)  
>> planned for
>> |> Ruby 1.9 or 2.0?
>> |
>> |Not that I remember hearing about. I'd certainly like to see it.
>>
>> We still don't have consensus on the name.  eigenclass?
>> In that case, should we rename singleton_method to eigenmethod?
>
> I wonder if this controversy has died down.   There are people with
> their favorites, sure, but does anyone really oppose singleton_class?

I'm for singleton_class.  It's what the official documentation has  
used for a long time now.  It's also not like it will be the only  
overloaded term in computing.

James Edward Gray II