On Fri, Jan 30, 2009 at 10:28 AM, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
> Hi,
>
> In message "Re: Object#singleton_class in Ruby 1.9?"
>    on Fri, 30 Jan 2009 20:15:17 +0900, "David A. Black" <dblack / rubypal.com> writes:
>
> |> Was Object#singleton_class (or #eigen_class or #meta_class) planned for
> |> Ruby 1.9 or 2.0?
> |
> |Not that I remember hearing about. I'd certainly like to see it.
>
> We still don't have consensus on the name.  eigenclass?
> In that case, should we rename singleton_method to eigenmethod?

I wonder if this controversy has died down.   There are people with
their favorites, sure, but does anyone really oppose singleton_class?

-greg


-- 
Technical Blaag at: http://blog.majesticseacreature.com
 Non-tech stuff at: http://metametta.blogspot.com
"Ruby Best Practices"  Book now in O'Reilly Roughcuts:
http://rubybestpractices.com