Put simply: 1.8.7 has features and behavioral changes that are 
compatible with neither 1.9 nor 1.8.6. So it's up to you.

Peter Szinek wrote:
> Guys, I am a bit confused ;-) So is it (not) recommended to switch to 
> 1.8.7? I'd like to, but I am not sure after this thread?
> 
> Cheers,
> Peter
> ___
> http://www.rubyrailways.com
> http://scrubyt.org
> 
> 
> On 2008.12.02., at 4:49, Mark Thomas wrote:
> 
>> On Nov 28, 3:36 am, Luc Heinrich <l... / honk-honk.com> wrote:
>>> On 27 nov. 08, at 16:27, Anatoly Mikhailov wrote:
>>>
>>>> As you may know Ruby 1.8.7 don't compatable with
>>>> Rails(http://www.rubyonrails.org/down)
>>>
>>> Uh, this page *explicitely* says: "We recommend Ruby 1.8.7 for use
>>> with Rails".
>>
>> Yay! It's been fixed. Probably due to this thread.
> 
> 
>