On Nov 14, 2008, at 4:42 PM, Stefan Lang wrote:

> I'm looking for a web framework that:
>
> 1) really works with Ruby 1.9
>
> 2) pure Ruby code (i.e. doesn't depend on C-extensions, Java  
> libraries...)
>
> 3) has an active community
>
> bonus points:
>
> 4) doesn't follow the "let's extend core classes whenever possible"  
> craze
>
> 5) good postgres support
>
> Does such a framework exist or am I asking for too much?
>
> Actually I would use Rails, the latest RC is advertised as Ruby 1.9
> compatible but I've immediately hit a couple of errors and I
> don't have the time ATM to fix compatibility errors in such a big
> codebase and push the changes upstream. What's more, the pure
> Ruby postgres driver doesn't work anymore.
>
> Merb fails with syntax errors with Ruby 1.9.
>
> Thanks,
>  Stefan
>

it's called ramaze.

a @ http://codeforpeople.com/
--
we can deny everything, except that we have the possibility of being  
better. simply reflect on that.
h.h. the 14th dalai lama