On Nov 14, 4:05   鮮 
> Hi,
>
> any idea why this happens?
>
> c:/ruby/lib/ruby/gems/1.8/gems/wxruby-1.9.9-x86-mswin32-60/lib/wxruby2.so:
> 126: The specified module could not be found. -
> c:/ruby/lib/ruby/gems/1.8/gems/wxruby-1.9.9-x86-mswin32-60/lib/wxruby2.so
> (LoadError)
> from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
> `require'
> from
> c:/ruby/lib/ruby/gems/1.8/gems/wxruby-1.9.9-x86-mswin32-60/lib/wx.rb:12
> from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
> `gem_original_require'
> from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in
> `require'
> from GetDataFromComet.rb:2
>
> The file is definitely in that directory.
>

Hello Henry,

You didn't see a popup indicating the missing DLL?

Looks like wxruby2.so depends on wxWidgets externall DLL, but cannot
comment more on wxRuby 2 since didn't played with it yet.
(if it was statically or dynamically linked).

Can you also indicate both your ruby and gem environment?

C:\ruby> ruby -v

C:\ruby> gem env

Regards,
--
Luis Lavena