> zlib and zlib-devel are installed (from yum). Supposedly ruby has zlib
> support built in. Is there anything I need to do to let ruby find
> zlib?
> 
> Thsnks!
> 
> Terry
> 
> [root@li48-219 ruby-1.8.7-p72]# gem install  zlib rails redcloth
> rmagick gettext libxml-ruby
> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require': no such file to load -- zlib (LoadError)


Ruby-zlib should be built into Ruby 1.8

you might want to try building ruby-zlib by hand

wget http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0.6.0.tar.gz
tar xvzf ruby-zlib-0.6.0.tar.gz
cd ruby-zlib-0.6.0
ruby extconf.rb && make && make install


then, I would try reinstalling Ruby Gems from source.


-- 
Posted via http://www.ruby-forum.com/.