2008/11/3 davetron5000 <davetron5000 / gmail.com>:
> Working on some code I wish to distribute via gem.  When I up the
> version and do a gem update my-code, gem reports that both the
> previous version and the new version are installed.  This doesn't seem
> to occur with any other gems that I have.  I cannot seem to figure out
> what's up with this.

It's normal behaviour. It doesn't hurt, since RubyGems
loads the newest version anyway when no specific version
is specified. And the old gem is still there in case another
gem depends on this specific version.

You can uninstall the old version with:

    gem uninstall gem-name -v some.version.number

Stefan