On Wed, Oct 15, 2008 at 1:05 PM, Erik Hollensbe <erik / hollensbe.org> wrote:
> Owein Herrmann wrote:
>>> I don't know if this is recommended usage anymore, but provided you
>>> haven't installed dbi with the provided setup.rb, "require 'dbi'" should
>>> work without the gem statements.
>> Hmmmm... that definitely does not work. When I say "require 'dbi'" it
>> returns true, but then dbh = DBI.connect('DBI:Mysql:money', 'mysqluser',
>> 'pass3') causes an exception about DBI not being defined... I'm not on
>> my ruby box right now, so I cannot give the exact notation... basically,
>> what I show above works, the two gem commands and then the require.
>
> Is this 1.9? I'm not sure how rubygems would be automatically required
> in 1.8.x.

Via RUBY_OPT

-- 
Technical Blaag at: http://blog.majesticseacreature.com | Non-tech
stuff at: http://metametta.blogspot.com