I am using jruby 1.1.4 and installed warbler 0.9.11 in Windows XP.  When
I run jruby -S warble war, I always get this.  It fails when rake
reaches the target war:jar.  I checked my JAVA_HOME and I can run jar
command in a command line.

** Execute war:jar
jar cf shoplet.war -C tmp/war .
/usr/bin/sh: call: command not found
rake aborted!
Command failed with status (127): [jar cf shoplet.war -C tmp/war ....]
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:971:in `sh'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:984:in
`call'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:984:in `sh'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1076:in
`sh'
D:/workspace/shoplet/vendor/plugins/warbler-0.9.11/tasks/../lib/warbler/task.rb:
174:in `define_jar_task'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in
`call'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:617:in
`execute'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in
`each'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:612:in
`execute'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:578:in
`invoke_with
_call_chain'
D:/jruby-1.1.4/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with
_call_chain'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:588:in
`invoke_prer
equisites'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`each'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:585:in
`invoke_prer
equisites'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:577:in
`invoke_with
_call_chain'
D:/jruby-1.1.4/lib/ruby/1.8/monitor.rb:191:in `mon_synchronize'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:571:in
`invoke_with
_call_chain'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:564:in
`invoke'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2019:in
`invoke_tas
k'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`top_level'

D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`each'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1997:in
`top_level'

D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_e
xception_handling'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1991:in
`top_level'

D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1970:in
`run'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_e
xception_handling'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in
`run'
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
D:/jruby-1.1.4/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:19:in `load'
d:\jruby-1.1.4\bin\rake:19
-- 
Posted via http://www.ruby-forum.com/.