The Neurochild wrote:
> I have a Debian 4 machine with Ruby 1.8.6 (installed from source) and
> some gems including Rails 2.1 and Phusion Passenger 2.0.3 (mod_rails,
> which needs fastthread and rack gems). I want to update to the latest
> patch of that version (1.8.6-p287)

Do you have a particular reason to do this?

I only ask because there have been bad problems with Rails running under 
Ruby released versions later than p114. I'm not sure if p287 has fixed 
them all (perhaps others can comment on this). If you want stability in 
production, and your distribution has a p111 or p114 plus just the 
security patches, then personally I'd stick with that.

Unfortunately there is no official "stable" branch of Ruby at present - 
that is, one which receives security fixes only. The 1.8.6 branch has 
received a number of "enhancements" which have turned out to break 
things. It's therefore up to the distro maintainers to provide their own 
"stable" version of Ruby.
-- 
Posted via http://www.ruby-forum.com/.