Bruno Moura wrote:
> sudo ./configure
> sudo make
> sudo make install
> 
> ruby -v
> 
> ruby 1.8.7 (2008-06-20 patchlevel 22) [i686-linux])   ...it's ok

Now look in ext/zlib/mkmf.log - that will probably tell you why the zlib 
extension isn't being built. Post it here if it doesn't make sense.

Do you definitely have the zlib1g-dev package installed?

Hmm, perhaps you also need libssl-dev installed. Try that.

-- 
Posted via http://www.ruby-forum.com/.