That makes a lot of sense. Thanks for the clarification regarding the 
unicode range.

Since I don't have control over the JSON source, I would like to try to 
parse the JSON even if it results in a malformed unicode string. So 
today I tried switching from 'json' to the 'ruby-json' library. After 
some searching online, I didn't find any documentation on how to use it 
though. Primarily I don't know how to include or require it.

require 'ruby-json'
require 'rubyjson'

don't seem to work?
Any ideas are appreaciated.
Thank you very much
// pascal
-- 
Posted via http://www.ruby-forum.com/.