On Sep 29, 2008, at 07:34 , Jan Luehr wrote:

> Maybe nothing serious is a bit harsh - sorry about that.
> I'm looking for a reliable way to use perl code with ruby.
> Yoshida Masato's library seems to be unmaintained since 2001/2002,  
> never had
> a stable (1.0) release, was tested on linux 2.0 and is requiring  
> perl 5.6
> while I'm using 5.10
> Do you have any experiences apart from using LWP::Simple? Do you know
> projects or software currently using this libarary?

again... I don't mean to sound like a broken record... but DID YOU TRY  
IT???

ruby -I../../RubyInline/dev/lib -Ilib -rperl -e 'Perl.runtime.eval  
"print 1+1, \"\\n\""'
2

that works... RIGHT NOW... against perl 5.8.8. I don't have perl 5.10  
anywhere and I'm not willing to install it just to test it out for this.

If you're having actual problems... that's one thing and we can work  
with you on that. But you seem to just be harping on something for  
being old. Maybe it is unmaintained because it hasn't needed  
maintenance?