On Sep 20, 3:32  𲮮
> Phlip wrote:
> > tekwiz wrote:
>
> >> This is what roodi would have me do
>
> >> (0...str.size).each do |i|
> > It leaves you closer to a refactor to .map or .inject or .select or
> > .reject or .delete_if or .each_index or .each_with_index or ...
>
> It also hints at:
>
>   

So, it's a code-readability issue and not a functional or complexity
issue?

--
    TekWiz