> You'll need to downgrade to rubygems 1.1.1.

You don't have to. This topic has been discussed before:

https://groups.google.com/group/ruby-talk-google/tree/browse_frm/thread/f922ec9ef52af7e4/79ed5e66091744bb?rnum=1&_done=%2Fgroup%2Fruby-talk-google%2Fbrowse_frm%2Fthread%2Ff922ec9ef52af7e4%3Ftvc%3D1%26#doc_cd01f5645fdf9c8d

gegroet,
Erik V.