I can't get rubygems to install, and I don't understand what the problem 
is or what to do about it.

I'm running on Kubuntu Linux 8.04.1

I compiled ruby-1.8.6-p114 a couple of days ago. Note:

tomc@tom-desktop:/$ which ruby
/usr/local/bin/ruby
tomc@tom-desktop:/$ ruby -v
ruby 1.8.6 (2008-03-03 patchlevel 114) [i686-linux]
tomc@tom-desktop:/$  

I downloaded rubygems-1.2.0.tgz, unpacked it into /usr/local/src/.

Then...

tomc@tom-desktop:/usr/local/src/rubygems-1.2.0$ ruby setup.rb
./lib/rubygems/spec_fetcher.rb:1:in `require': no such file to load -- 
zlib (LoadError)
        from ./lib/rubygems/spec_fetcher.rb:1
        from ./lib/rubygems/source_index.rb:10:in `require'
        from ./lib/rubygems/source_index.rb:10
        from ./lib/rubygems.rb:767:in `require'
        from ./lib/rubygems.rb:767
        from setup.rb:22:in `require'
        from setup.rb:22

A couple of listings which may help

my ruby compile listing: http://pastie.org/275615

output of "$ locate zlib" => http://pastie.org/275612

I'm barely able to do this stuff, and certainly don't understand what 
the complaint is about. I've had one kind, knowing soul look at this and 
he didn't find the problem. To someone here, I'm sure it'll be obvious. 
I sure hope he/she reads this!

Thanks,

Tom

-- 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< tc / tomcloyd.com >> (email)
<< TomCloyd.com >> (website) 
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~