Thanks for the new Ruby installer.

There are a few bits that I find odd:

I noticed that the zlib extension is both in 1.8 and in site_ruby for
some reason.

The curses extension can crash Ruby easily when used improperly.

irb(main):001:0> require 'curses'
=> true
irb(main):002:0> Curses.close_screen
(irb):2: [BUG] Segmentation fault
ruby 1.8.6 (2008-08-11) [i386-mswin32]


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Thanks

Michal