One of the comments on the spock blog says:

> Instructions how to get it work on FC8. ...
> You have to download http://gregoire.lejeune.free.fr/ruby-xslt_0.9.3.tar.gz
> Follow instructions there (ruby extconf.rb; make; make doc; make install)
> This will leave xslt.rb in /usr/lib/ruby/site_ruby/1.8/xml/xslt.rb
>
> Apparently, Ruby needs libxslt.rb there, so do:
> sudo mv /usr/lib/ruby/site_ruby/1.8/xml/xslt.rb
>   /usr/lib/ruby/site_ruby/1.8/xml/libxslt.rb
>
> Subsequently, spock runs.

Maybe that will help?