I seem to have run right into my ignorance again.

Working on Kubuntu Linux 8.04.1, I've a fresh compile of ruby 1.8.6. Irb 
runs. I have installed rubygems from the adept package manager - the 
install produced no errors of any kind. I've installed a number of gems, 
including the marvelous webby, which I'm now trying to use it (I have 
considerable experience with it). I'm not getting anywhere. To wit:

$ webby
bash: webby: command not found
$


On a hunch, I did this:

irb(main):001:0> require 'rubygems'
LoadError: no such file to load -- rubygems
        from (irb):1:in `require'
        from (irb):1
irb(main):002:0> require 'webby'
LoadError: no such file to load -- webby
        from (irb):2:in `require'
        from (irb):2
irb(main):003:0> require 'activerecord'
LoadError: no such file to load -- activerecord
        from (irb):3:in `require'
        from (irb):3
irb(main):004:0>   

I don't understand what's happening. Is this a path problem? If so, how 
do I fix it? I've change my path before, so that's not an issue. I just 
don't know what is needed here, if anything.

Finally, if one needs to modify the path, manually, after any of these 
things I've just done (installation of ruby, rubygems, and a bunch of 
gems), why isn't that stated somewhere so perpetual amateurs like me can 
get a clue? I'm not born knowing this stuff.

I'd be really grateful for any help offered.

Tom

-- 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< tc / tomcloyd.com >> (email)
<< TomCloyd.com >> (website) 
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~