Stefano Crocco wrote:
> It's part of the facets library. Unfortunately, ri doesn't show the name 

Aah, thanks. Yes, I used facets last year...

However, would be grateful if you could tell me how to decide what to 
use in the require statement for a facets class. Whenever i use facets, 
i struggle to figure out the require statement. What is shown in the 
examples often does not work.

Some while back I came upon ProgressBar. It took me a while of trying to 
figure out the require.

Then Console::ANSICode gives an example: "include Console::ANSICode"

irb(main):011:0>   include Console::ANSICode
NameError: uninitialized constant Console
  from (irb):11

I tried many combinations, finally "require 'facets/ansicode'" did not 
give an error but still the "include Console::ANSICode" gives the error 
above.
I can't remember if I managed to make the example run or not.

(I have started with require rubygems and facets.)
-- 
Posted via http://www.ruby-forum.com/.