Whooops, I'm getting ahead of myself here,

I meant I'm using mod_ruby-0.9.4. and is
Apache::requrest.prev.uri a feature of 0.9.5 only?

-- 
Alan Chen
Digikata LLC
http://digikata.com