For reference, that is obsolete as somebody else mentioned.

On Debian, you can build and install RubyGems as long as you have got 
zlib1g-dev before you start your build of Ruby.

Long-dead thread, but it was unresolved...
kingdon / tuesdaystudios.com

Lukas Rieder wrote:
> This solved my zlib LoadError issue:
> 
> wget http://www.blue.sky.or.jp/atelier/ruby/ruby-zlib-0.6.0.tar.gz
> tar xvzf ruby-zlib-0.6.0.tar.gz
> cd ruby-zlib-0.6.0
> ruby extconf.rb && make && make install
> 
> (and reinstall your rubygems from source)
> 
> Have a nice day,
> 
> 
> Lukas Rieder

-- 
Posted via http://www.ruby-forum.com/.