Hi all,

Recently downloaded Ruby and I'm really impressed so far. Want to try out
the tk integration but none of the tk samples (in rbcw144.zip) work:

bash-2.04$ ruby tkhello.rb
//c/Prg/ruby/lib/tcltklib.rb:7:in `+': failed to convert nil into String
(TypeError)
        from //c/Prg/ruby/lib/tcltklib.rb:7
        from //c/Prg/ruby/lib/tk.rb:7:in `require'
        from //c/Prg/ruby/lib/tk.rb:7
        from tkhello.rb:1:in `require'
        from tkhello.rb:1

I've downloaded the latest cygwin (1.1.1), including tcltk,
from sourceware.cygnus.com so the version of tcltk shouldn't be the
problem. Or?

Couldn't find info in FAQ so I'm posting here. Any info/help appreciated.

Regards,

Robert Feldt
feldt / ce.chalmers.se