On Aug 4, 2008, at 08:28 AM, matt neuburg wrote:

> I am really just not having any luck with rdoc / ri these days.  
> Because
> the new version of rdoc promised that File#read would finally succeed
> (automatic lookup of methods in the supercclass), I downloaded it. It
> didn't change anything so I rebuilt my documentation from scratch. Now
> fast-ri is broken. Can anyone divine from this error what's gone wrong
> and what I should do? Thx - m.
>
> $ qri String
> /usr/local/lib/ruby/1.8/yaml.rb:133:in `transfer': invalid subclass
> (TypeError)
>        from /usr/local/lib/ruby/1.8/yaml.rb:133:in `node_import'
>        from /usr/local/lib/ruby/1.8/yaml.rb:133:in `load'
>        from /usr/local/lib/ruby/1.8/yaml.rb:133:in `load'
>        from /usr/local/lib/ruby/1.8/rdoc/ri/ri_descriptions.rb:72:in
> `deserialize'

Looks like qri is using RDoc 1.0.1, which is shipped with ruby.  RDoc  
2's on-disk YAML format is not backwards compatible with RDoc 1.  RDoc  
2 can read RDoc 1's format due to some use of regular expressions.   
fast-ri would need to be updated to read the RDoc 2 classes.