Stefan Lang wrote:
> 2008/8/4 Frioffol Friofool <friofool / gmail.com>:
>> [root@compute test_projet_rails]# gem -v
>>
>> What's wrong with my configuration ?
> 
> Maybe you have two Ruby installations. The one that is started by "ruby"
> and "irb" doesn't have a gem installation. The one that the "gem" 
> command
> uses, does.
> 
> Compare the output of:
> 
>     $ cat `which gem` | head -n 1
> 
>     $ ls -l `which ruby`
> 
> Stefan

bingo !
that was the problem...

[root@compute test_projet_rails]# cat `which gem` | head -n 1
#!/usr/bin/ruby
[root@compute test_projet_rails]# ls -l `which ruby`
-rwxr-xr-x 1 root root 1931641 aoƦĥ  1 11:40 /usr/local/bin/ruby

but how can i update the path and use just one ruby version ?

i tried to install ruby sources first but for different reasons, i use 
the fedora installer 'yum'.

i'm not an expert in system and i need some help...

thanks a lot

-- 
Posted via http://www.ruby-forum.com/.