With a fresh install of Rubygems, when I issue a "gem -h" command, the 
result is:

/usr/bin/gem:23: uninitialized constant Gem::GemRunner (NameError)

Background:

With a fresh installation of Kubuntu 8.04.1 Linux, I installed ruby 1.8 
with "apt-get...", and then installed rubygems 1.8 from the tar file at 
rubyforge. There were problems, so I figured the rubygems install done 
that way was a bad idea. Basically, I was getting an odd message when 
trying to install the webby gem. Three other gems did install without 
error, including sequel.

So, I reinstalled ruby 1.8, and rubygems from the Adept package manager, 
  at which point I got the unexpected problem above.

I don't know what's wrong or how to get a good install of rubygems, at 
this point. All suggests greatly appreciated.

Thanks,

Tom


-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd
Bellingham, Washington, U.S.A: (360) 920-1226
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~