Max Williams wrote:

> Doh, just checked, i have make installed already.  I'm going to shut up 
> and let someone else answer now :)

aptitude ruby-full will get you ruby1.8-dev. Does this show it?

   aptitude search ruby1.8-dev | grep ^i

I think that's the next step towards mkmf. You also need a little gcc!