Actually, looking at this error "no such file to load -- mkmf"
makes me think that maybe i need to install 'make': is that the case? 
If so, is it just a simple "sudo apt-get install make"?
-- 
Posted via http://www.ruby-forum.com/.