Hello,

I am new using Ruby and I would like to use OpenGL for Ruby. I tried
this week-end to compile and run this extension on Windows 2000 using
Microsoft Visual C++ 6.0 and Ruby-mswin32 1.6.6. I compiled without
any problem the two DLLs but when I tried to run the example I had
problems. The line 'require "opengl"' makes a segmentation fault. If I
try to use only glut, when I run the line 'GLUT.DisplayFunc display',
with display created with 'display = Proc.new { ... }' , I have the
error that the parameter is not an object...
So comeone could help me ?

I also tried to do this using Linux but I saw that I do not have glut
for Linux... But it seems that there is an error in the Makefile
generated with extconf.rb : the line "LIBS=libruby.a -l..." should
maybe be "LIBS=-lruby -l..." because gcc does not find the libruby.a
library with the first version, except if it is in the current
directory...

regards,
Vincent ISAMBART
French student in IT