/usr/local/lib/ruby/1.8/openssl/ssl.rb:26: uninitialized constant
OpenSSL::SSL::VERIFY_PEER (NameError)
        from /usr/local/lib/ruby/1.8/openssl.rb:23:in `require'
        from /usr/local/lib/ruby/1.8/openssl.rb:23

Yeah the subject says it all really, I get this error everytime I try
to run a script that uses the socket library, although it sometimes
works, weird. Any idea why this is happening?

Thanks,
Lee