>>would just grab the tarball for 1.9 and run ./configure --program- 
>>>suffix=19.  You already have all the pieces you need.
[Nation, Carey] 
Maybe.  If configure tells you that gcc can't create executables,
install xcode 2.x if you don't have it.