Guillermo.Acilu / koiaka.com wrote:
> [Note:  parts of this message were removed to make it a legal post.]
> 
> Hello guys,
> 
> I am working with the standard Ruby delivered within Mac OS X Leopard. It 
> is the version 1.8.6 patch level 111. Is it possible to apply patches? or 
> do they come with Mac OS X updates? If I should apply them manually up to 
> which patch level I should go without braking the Ruby environment? Can I 
> go to 1.9.0?
> 
> Thanks in advance for your answer,

I don't think anybody here will recommend touching apple's ruby version, 
as this will get you in trouble sooner or later

If you want/need a more recent version, you should take a look at Fink 
or MacPorts.

Hope this helps.