-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bob Florian wrote:
| I've just switched from Window XP to a new Vista machine and my Rails
| app is crashing with apparently random segmentation faults -- each time
| seems to be in a different location. Has anyone else had a similar
| experience and, if so, is there a solution?  I've spent some time
| googling around for information but I don't have a clear picture about
| ruby support on Vista.  Some people are clearly having problems with
| ruby and vista but others say things are working for them.  I'm running
| ruby 1.8.6, rails 2.0.3, and mysql 5.0.  Any help would be greatly
| appreciated.

Off the top of my head:
- - How are you running Ruby/Rails? Administrator (i.e. via 'Run as..', or
as the higher-privileged-but-not-quite-and-actual-admin admin account)?
- - Could you stack trace the segfault? Chances are, it is always at the
same location, code-wise, but Vista distributes memory in a
randomish-way to make buffer overflows more difficult.
- - Is Ruby installed into a directory where only an elevated account has
write access (i.e. %windir%\Programs, or something similar)?

I've had no issue with Ruby installed into %windir%\Ruby on Vista in
both RC2 and RTM pre-SP1.

- --
Phillip Gawlowski
Twitter: twitter.com/cynicalryan
Blog: http://justarubyist.blogspot.com

~   "I'm a simple man with complex tastes."  -Calvin
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkg0beIACgkQbtAgaoJTgL9HxACeMMBJgOFJkQMG3X5KUTxj6Pe9
+JAAn255sRIcl7w0FnW8wqGgjnJcZE+7
=oicv
-----END PGP SIGNATURE-----