My Ruby installation is from the Ubuntu package repository. Yesterday,
I upgraded my system to Heron and since then one of my Ruby scripts
stopped working. I traced the problem to this:

  $ ruby -e"p ENV['ROLL_PATH']"
  "/home/trans/Company/TigerOps/programs"

  $ sudo ruby -e"p ENV['ROLL_PATH']"
  nil

At first I though it might have something to do with sudo itself, but:

  $ echo $ROLL_PATH
  /home/trans/Company/TigerOps/programs

  $ sudo echo $ROLL_PATH
  /home/trans/Company/TigerOps/programs

So that's not it. Anyone have any idea what's going on?

My current version of Ruby is now:

  $ ruby -v
  ruby 1.8.6 (2007-09-24 patchlevel 111) [x86_64-linux]

Thanks,
T.