I hope this is an OK place to post this. I've been able to find another 
more promising place.

I'm running an extremely simple program, trying to start using the 
Hpricot gem. I don't understand two things with some error output I'm 
getting. Here's the program (obviously only a fragment at this time, but 
that's 'cause I get in trouble easily):

%w(rubygems logger hpricot ruby-debug).each{|lib| require lib }
doc = open("index.html") { |f| Hpricot(f) }
(doc/"div.page-content-div").inner_html      

Here's the console I'm seeing:

$ ruby --debug content_capture.rb
Exception `LoadError' at /usr/lib/ruby/1.8/rubygems/custom_require.rb:27 
- no such file to load -- hpricot
Exception `LoadError' at /usr/lib/ruby/1.8/rubygems/custom_require.rb:27 
- no such file to load -- encoding/character/utf-8
Exception `LoadError' at /usr/lib/ruby/1.8/rubygems/custom_require.rb:34 
- no such file to load -- encoding/character/utf-8
/var/lib/gems/1.8/gems/hpricot-0.6/lib/hpricot/builder.rb:11: warning: 
`&' interpreted as argument prefix
Exception `LoadError' at /usr/lib/ruby/1.8/rubygems/custom_require.rb:27 
- no such file to load -- ruby-debug
$

First of all, there's nothing in this output which looks like a usable 
(by me) trace - the first thing I want to know is WHERE in my program is 
the error occurring. There aren't exactly many possibilities, but I'm 
still not understanding why there isn't a traceback to the point of 
origin of the problem in my tiny program. Makes no sense to me. I'm left 
guessing. Am I missing something?

Secondly, I don't see what the problem is. The file I'm trying to open 
is assuredly there, and where I'm saying it is. Is this all errors from 
hpricot?

Any help would be much appreciated. I'm beached at this point.

t.

--