Hi,

I'm trying to take a rails project built on gem version 1.2.6 and
upgrade it to 2.0.2.  So far, I haven't changed anything except this
line in the config/environment.rb file ...

RAILS_GEM_VERSION = '2.0.2' unless defined? RAILS_GEM_VERSION

when I start the server, I get this error:

[me / mymachine]~/w/dps% ruby script/server
=> Booting WEBrick...
./script/../config/../vendor/rails/railties/lib/initializer.rb:334:in
`send': undefined method `session=' for ActionController::Base:Class
(NoMethodError)
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:334:in `initialize_framework_settings'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:333:in `each'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:333:in `initialize_framework_settings'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:330:in `each'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:330:in `initialize_framework_settings'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:100:in `process'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:47:in `send'
        from ./script/../config/../vendor/rails/railties/lib/
initializer.rb:47:in `run'
         ... 11 levels...
        from /usr/local/apache2/htdocs/dps/vendor/rails/activesupport/
lib/active_support/dependencies.rb:495:in `require'
        from /usr/local/apache2/htdocs/dps/vendor/rails/railties/lib/
commands/server.rb:39
        from script/server:3:in `require'
        from script/server:3

What does it mean and any ideas how to fix/troubleshoot?  Thanks, -
rizwana